Recent Posts

Pages: [1] 2 3 ... 10
1
AIS Dispatcher / Re: aisdispatcher BeagleBone Black Rev C ArmV7
« Last post by SV3EXP on 25 April, 2017, 04:49:49 pm »
Finally after many hours of debugging I've found a solution to run aisdispatcher on my ARM boards.

The issue seems to be that aisdispatcher binary looks for file "/lib/ld-linux.so.3" that does not exist in my system (and in many others)

The solution is to link this file to "/lib/ld-linux-armhf.so.3"

sudo ln -s /lib/ld-linux-armhf.so.3 /lib/ld-linux.so.3

Now aisdispatcher works on ARMv7 (Ubuntu 14.04.5 LTS, Debian GNU/Linux 8 etc)


Hi,

Could someone please provide a version of aisdispatcher compiled for armV7 32 bit that will run on a BeagleBone Black or temporarily lend me the source code under an NDA so I can build it? I have tried both the current compiled  glibc and uClibc  arm versions of aisdispatcher from this site but they will not execute - gives:- -bash: ./aisdispatcher: No such file or directory
2
AIS Dispatcher / Re: AISDISPATCHER v1.2 on 64bit Linux broken - libc.so.6
« Last post by gavink on 15 April, 2017, 10:26:30 pm »
I'm not a linux user so I don't know ... but would post 3 of this thread http://forum.aishub.net/ais-dispatcher/ais-dispatcher-open-source/ be of any help, as an alternative to AISdispatcher if need be?
3
AIS Dispatcher / Re: AIS Dispatcher hangs after a while (glibc version). latest
« Last post by goelectric on 13 April, 2017, 08:29:53 pm »
Has anyone tried the alternative ais forwarding app kplex http://www.stripydog.com/kplex/? It is opensource on github. How stable is it?
4
AIS Dispatcher / Re: AISDISPATCHER v1.2 on 64bit Linux broken - libc.so.6
« Last post by goelectric on 13 April, 2017, 07:35:18 pm »
The private symbol __get_cpu_features@@GLIBC_PRIVATE has moved from
libc6 to ld-linux-x86-64.so.2

 my
suggestion would be that you need to recompile against the newer libc.
5
AIS Dispatcher / AISDISPATCHER v1.2 on 64bit Linux broken - libc.so.6
« Last post by goelectric on 13 April, 2017, 06:59:01 pm »
Dear AISHUB,

aisdispatcher no longer runs on linux due to the following problem

./aisdispatcher: relocation error: ./aisdispatcher: symbol __get_cpu_features, version GLIBC_PRIVATE not defined in file  :'(with link time reference

It looks like a recent security update to libc-2.17.so (which libc.so.6 links to) has removed the symbol.

Can you please re-compile aisdispatcher against the new location of GLIBC_PRIVATE?
6
AIS Dispatcher / Re: AIS Dispatcher hangs after a while (glibc version). latest
« Last post by killer3dfx on 10 April, 2017, 07:23:04 pm »
Hello, I have the same problem, the software hung after some minutes, hours of use, i wrote a batch script that runs every minute to check the AisDispatatcher webserver, and if it is hung, kill the app and restart it. it is necessary to set auto connect feature in the software.
7
Software development / Re: AIS Newbie - Timestamps from the NMEA Sample
« Last post by malcolmh on 07 April, 2017, 09:13:16 am »
Full UTC date/time data is to be found in Base station reports, of which there are a few in the sample. Ship position reports only give the seconds after the UTC minute in their timestamps. To determine the full time, it will be necessary to fast forward to the Base Station report to get the date, hour & minute for the preceding messages.
8
Software development / AIS Newbie - Timestamps from the NMEA Sample
« Last post by pwillemann on 05 April, 2017, 06:51:26 pm »
I have been asked to retrieve AIS messages from the NMEA Sample data (http://www.aishub.net/nmea-sample.php) which contains about 3 minutes of data.  I used a third party program https://github.com/dma-ais/AisLib and can successfully get the AIS messages.  For now, I am only interested in AIS message #1.  I need to extract some fields from the message and send them to another program.  This program requires a timestamp and I am not really sure how to get timestamps from the sample data.  Am I suppose to use an AIS message #4 to get the basic time and then use the UTCSec field in the AIS message #1?  What if my data set doesn't immediately have an AIS message #4?  Am I suppose to read the sample data twice?  Any help would be appreciated.


Thanks
Phil
9
AIS Decoder / Ais decode compile problem
« Last post by tetramonium on 05 April, 2017, 03:58:48 am »
Hi
I have errors when i do make
help me please
xubuntu 16.04

└─ $ ▶ make
[  5%] Linking C shared library libaisdecoder.so
CMakeFiles/aisdecoder_dynamic_lib.dir/src/lib/receiver.c.o : Dans la fonction « __mac_g » :
receiver.c:(.text+0x0) : définitions multiples de « __mac_g »
CMakeFiles/aisdecoder_dynamic_lib.dir/src/lib/filter.c.o:filter.c:(.text+0x290) : défini pour la première fois ici
CMakeFiles/aisdecoder_dynamic_lib.dir/src/lib/receiver.c.o : Dans la fonction « __mac_c » :
receiver.c:(.text+0x40) : définitions multiples de « __mac_c »
CMakeFiles/aisdecoder_dynamic_lib.dir/src/lib/filter.c.o:filter.c:(.text+0x2d0) : défini pour la première fois ici
collect2: error: ld returned 1 exit status
CMakeFiles/aisdecoder_dynamic_lib.dir/build.make:250 : la recette pour la cible « libaisdecoder.so.1.0.0 » a échouée
make[2]: *** [libaisdecoder.so.1.0.0] Erreur 1
CMakeFiles/Makefile2:67 : la recette pour la cible « CMakeFiles/aisdecoder_dynamic_lib.dir/all » a échouée
make[1]: *** [CMakeFiles/aisdecoder_dynamic_lib.dir/all] Erreur 2
Makefile:83 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2
10
AIS Dispatcher / Display Vessel name in Google Earth
« Last post by kaitahmak on 04 April, 2017, 07:11:24 am »
hi All ,

I have AIS Dispatcher running with Google earth connected as a network link - The data come in and displays on the map fine - but it does not show the vessel name. It does in the data on the side bar. Any ideas how I get it to show on the map above the vessels ?  Like it does with the Google Earth feed from Vessel Tracker <see attached>
Pages: [1] 2 3 ... 10